require PHP > 5.2.0 !